Kirjoittaja Aihe: xm1541  (Luettu 5383 kertaa)

Poissa c64suomalainen 2

  • Juniori
  • **
  • Viestejä: 11
  • Commodore Rulez!
    • Profiili
xm1541
« : Tammikuu 30, 2008, 13:26 »
Tuli tässä hankittua xm1541 kaapeli. olen kokeillut gui4cbm4win ohjelmalla tiedostojen siirtoa, mutta ohjelma ei tunnista asemaa. Kokeilin myös The Star Commander Version 0.82
ohjelmaa mutta windows xp alkoi temppuilemaan.
Siis kysymykseni on mikä olisi paras ja helpoin tapa siirtää tiedostoja tietokoneelta c64:lle? Yksityiskohtaisista ohjeistakaan ei olisi haittaa.
Kiitos etukäteen.  :)

Poissa Syntax_Error

  • Metusalem
  • *****
  • Viestejä: 109
  • Load"*",8,1
    • Profiili
Re: xm1541
« Vastaus #1 : Tammikuu 30, 2008, 15:29 »
XP ei ole kovinkaan hyvä noiden vanhojen DOS ohjelmien kanssa. Paras olisi hoitaa homma puhtaassa dos tilassa esim käynnistyslevykkeellä.

Tämän lisäksi olisi hyvä olla FAT32 tai FAT16 osio kiintolevyllä josta tarvittavat tiedostot sitten löytyy. NTFS osiotkin on kyllä mahdollista saada dossissakin pelaamaan, mutta vaati reilummin virittelyä.
Avira Antivir:in sivuilta sai yhden boottikorpun, josta modaamalla sai dossissa pelaavan buuttikorpun NTFS tuella.

Star Commander ohjelmalla ja puhtaassa DOS-tilassa hoidettu siirto toimii varmimmin.
NT Rautasen sivuilla oli muistaakseni hommasta kanssa jotain. Luultavimmin olet ne sieltä jo katsonutkin.
5 rem - Sekodemo :) -
10 N=INT(200*RND(0)+1)
20 PRINT CHR$(N);
30 GOTO 10

Poissa c64suomalainen 2

  • Juniori
  • **
  • Viestejä: 11
  • Commodore Rulez!
    • Profiili
Re: xm1541
« Vastaus #2 : Tammikuu 30, 2008, 17:26 »
latasin koneelle DOSBox 0.72 ohjelman. Nyt tuo star commander toimii, mutta kun yrittää katsoa levykkeen sisällön niin tulee ilmoitus drive8: not present. Muutin asetuksia NT rautanen sivujen mukaan, mutta ei ala toimimaan.

Poissa Nila

  • Tulokas
  • *
  • Viestejä: 4
  • I love YaBB 1G - SP1!
    • Profiili
Re: xm1541
« Vastaus #3 : Helmikuu 07, 2008, 19:30 »
Itse olen siirrellyt onnistuneesti t64 tiedostoja WAV-PRG:n ja sellaisen adapterin avulla. Adapteri on c-kasetin näkönen ja siitä lähtee johto jonka päässä on tavallinen plugi. Plugi stereoihin, kasetti kuusnepan kasetti-asemaan ja WAV-PRG:llä filu soimaan. Hyvin on pelit latautunu kun on saanut sopivan äänenvoimakkuuden säädettyä .

Poissa Aki

  • Juniori
  • **
  • Viestejä: 19
  • Commodore Rulez!
    • Profiili
Re: xm1541
« Vastaus #4 : Helmikuu 08, 2008, 07:27 »
Ei toimi DOSboxissa, kokeilin itsekkin. Hommaa jostain kierrätyskeskuksesta parilla eurolla joku vanha dos-kone ja tee sillä :)

Poissa Syntax_Error

  • Metusalem
  • *****
  • Viestejä: 109
  • Load"*",8,1
    • Profiili
Re: xm1541
« Vastaus #5 : Joulukuu 27, 2008, 21:19 »
Kunpa joulupukki olisi tuonut tämmösen:
http://plaza.fi/edome/uutiset/seuraavan-sukupolven-kuusneba-retroilua
Tuo olisi todella tervetullut tuohon Disc-image ongelmaankin. Tiedostot kun saisi nopeasti muistikortille ja sitten vain rock 'n' roll. ;)
« Viimeksi muokattu: Joulukuu 27, 2008, 21:22 kirjoittanut Syntax_Error »
5 rem - Sekodemo :) -
10 N=INT(200*RND(0)+1)
20 PRINT CHR$(N);
30 GOTO 10

Poissa Nepa

  • Tulokas
  • *
  • Viestejä: 2
  • Commodore Rulez!
    • Profiili
Re: xm1541
« Vastaus #6 : Lokakuu 22, 2009, 20:26 »
Ovat hiukan hankalia joskus saada toimimaan nuo x1541-perheen kaapelit nykykoneiden kanssa. Perusongelma on moniajo: käyttöjärjestelmä jakaa prosessoriaikaa ohjelmien (ja itsensä) kesken, mikä sotkee siirron ajoitukset. DOSsissa kun ei ollut moniajoa, siirto-ohjelma sai koko koneen itselleen, eikä ongelmaakaan ollut. Koska emulaattorit pyörivät Windowssin päällä, eivät vanhat DOS-pohjaiset siirto-ohjelmat varmaankaan toimi kovin hyvin itse tehtävässään, vaikka käyntiin lähtevätkin.

Itse käytän Linuxia, enkä ole koskaan Windowssissa tuota kokeillut tehdä, joten suoraan en osaa auttaa. Huomasin kuitenkin Linuxille omaa XM-kaapeliani konffatessani, että oletusasetuksilla se ei toimi, koska ohjelma (OpenCBM) olettaa sen olevan XA1541. Näillä asetuksilla aseman moottori jää pyörimään, eikä ohjelma tunnista asemaa. Kernel-moduulille pitää kertoa, että kyse on XM-kaapelista. Linuxin tapauksessa se sujuisi sivun http://opencbm.trikaliotis.net/opencbm-9.html ohjeiden mukaan. Minulla /etc/modules.conf:ssa lukee (jos joku sattuisi Linuxia käyttämään)

alias char-major-10-177 cbm
options cbm cable=0 reset=-1


Windowsissa kyse voisi olla samasta asiasta (etenkin, jos moottori jää pyörimään, mitä aloittaja ei kylläkään postissaan maininnut). Lisäksi kyseessä voisivat olla rinnakkaisportin asetukset, joiden suhteen siirto tuntuu myös olevan ronkeli. Sivulla http://www.trikaliotis.net/opencbm näytettäisiin käsittelevän asiaa. ("OpenCBM refuses to work on my Windows machine, what can I do?")

Lykkyä tykö kaikille kaapeloitsijoille! :)

Poissa Jake64

  • Metusalem
  • *****
  • Viestejä: 141
  • Commodore Rulee!
    • Profiili
Re: xm1541
« Vastaus #7 : Lokakuu 23, 2010, 22:29 »
Vihdoin ja viimein sain laiteltua XM1541-kaapelin ja 1541 aseman kiinni PC:hen. Löysin myös hyvän ohjelman, joka toimii XP:ssä. Monet olivat noita DOS-versioita.

Kyseinen ohjelma on Prg-Mover 0.42e beta. Ohjelma käyttää Opencbm:ää ym. ohjelmia hyväkseen ja mahdolllistaa komennot, siirrot ym. windowsissa.
Ohjelma nettisivulta http://www.tech-ecke.de/pc_tools.htm voi ladata 32-bit tai 64-bit windows-version.
Ohjelman hyvä piirre on se, että ajurit voi asentaa ohjelman avulla ja poistaa sitten, kun ei tarvitse siirtää. Nuo ajurithan vaikuttavat rinnakkaisportin toimintaan, joten jos
ajurit on asennettu, niin tulostus ei toimi. Ihmettelin itsekkin,kun yritin tulostaa ja etsiä vikaa koneesta. Sitten muistin kokeilleeni näitä siirto-ohjelmia ja Prg-Moverin käyttämät ajurit olivat vielä päällä. :-[
« Viimeksi muokattu: Lokakuu 24, 2010, 00:45 kirjoittanut Jake64 »

Tags: