Kirjoittaja Aihe: Commodore 128d levykeasema  (Luettu 903 kertaa)

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Commodore 128d levykeasema
« : Tammikuu 22, 2018, 18:47 »
Tutulta tuli commodore 128d pöydälle tarkistukseen, viallisen levyaseman takia.
Koneeseen virrat kytkettyä, alkaa aseman vihreä valo vilkkumaan. Vilkuttaa kaksikertaa peräkkäin ja pieni tauko. Sama sykli jatkuu.
Moottori pyörii kokoajan.
U16 piiri on todella kuuma, hetken virtojen oltua päällä.
Ei siinä sormeaan kauaa kestä pitää.
Ettei tää liian helpoksi mene, joku on katkaissut lukupään jousen, joten lukupää on ylhäällä kokoajan.
Jos jollain tuota jousea löytyy saa tarjota :)
Yleensä en näitä asemia tykkää korjata, mutta jos nyt sitten pakolla sörkkis :)
Olisko Virgolla tietoa näistä asemista?

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #1 : Tammikuu 22, 2018, 18:59 »
Tutulta tuli commodore 128d pöydälle tarkistukseen, viallisen levyaseman takia.
Koneeseen virrat kytkettyä, alkaa aseman vihreä valo vilkkumaan. Vilkuttaa kaksikertaa peräkkäin ja pieni tauko. Sama sykli jatkuu.
Moottori pyörii kokoajan.
U16 piiri on todella kuuma, hetken virtojen oltua päällä.
Ei siinä sormeaan kauaa kestä pitää.
Ettei tää liian helpoksi mene, joku on katkaissut lukupään jousen, joten lukupää on ylhäällä kokoajan.
Jos jollain tuota jousea löytyy saa tarjota :)
Yleensä en näitä asemia tykkää korjata, mutta jos nyt sitten pakolla sörkkis :)
Olisko Virgolla tietoa näistä asemista?


Virrat mitattu asemalle menevistä johdoista ja löytyy 12.34v ja 5.09v, elikkäs virtalähde toimii ainakin.

Poissa virgo

  • Vuoden Foorumilainen 2014
  • Metusalem
  • ******
  • Viestejä: 1046
  • Retroilija henkeen ja vereen
    • Profiili
    • Genetic point web
Vs: Commodore 128d levykeasema
« Vastaus #2 : Tammikuu 23, 2018, 03:37 »
Pari vilkkua kertois Rom virheestä mutta U16 74ls06 kuumeneminen kertoo jostain muuta lisäksi
IC ei pitäs missään tilanteessa kuumita niin ettei niihin pystyis koskemaan
lähtisin tuon inverterin vaihdolla liikkeelle
jousen voi pölliä jostain PC lerputtimesta harmi ettei niitä ole enään oikein liikkeellä

ftp://www.zimmers.net/pub/cbm/schematics/drives/new/1571/index.html
Genetic-point Amiga BBS: g-point.tunk.org ports 500 & 1024
Genetic-PET C64 BBS:g-pet.tunk.org port 1025
or g-point.tunk.org port 1025

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #3 : Tammikuu 23, 2018, 06:27 »
Nyt tuntuu, että tuo jousion pienin murhe tässä :)
Kävin vähän läpi yöllä innostuksissani noita pinnejä piireistä.
Maa on ok, mutta esim DOS ROM maa pinni+vss pinni,  eli pinni 28 piippaa myös. Tai mittari piippaa kerran lyhyesti.
Joku oikosulku taitaa olla :)
Piirilevyltä löytyi myös joku hyppylanka.
Kuvan oikeassa alalaidassa.
« Viimeksi muokattu: Tammikuu 23, 2018, 07:35 kirjoittanut junnu78 »

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #4 : Tammikuu 23, 2018, 07:38 »
Otin piirilevyn alasuojapellin irti ja nyt ei piippaa maan ja vcc välillä.
Kokeilin varovasti koneessa ja nyt vihreä valo palaa kokoajan ja moottori ei pyöri ollenkaan.
Pitääpi tutkiskella lisää :old:
Ihmettelin että miksi pellin poisto tuohon auttoi, kun siellä on suoja kuitenkin ettei saa kosketusta piirilevyyn.

Poissa virgo

  • Vuoden Foorumilainen 2014
  • Metusalem
  • ******
  • Viestejä: 1046
  • Retroilija henkeen ja vereen
    • Profiili
    • Genetic point web
Vs: Commodore 128d levykeasema
« Vastaus #5 : Tammikuu 23, 2018, 12:38 »
hyppylangasta tuskin kannattaa olla huolissaan pohjan pelti tekee saman asian kun on paikallaan kytkee kaksi GND potentiaalia toisiinsa
se miksi vika muuttui pellin poiston jälkeen vihjaisi siihen että C128 ja pellin välillä on jotain hämminkiä
jos piirilevy oli jo testatessa erillään rungosta veikkaisin hapettumia liittimissä


« Viimeksi muokattu: Tammikuu 23, 2018, 12:43 kirjoittanut virgo »
Genetic-point Amiga BBS: g-point.tunk.org ports 500 & 1024
Genetic-PET C64 BBS:g-pet.tunk.org port 1025
or g-point.tunk.org port 1025

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #6 : Tammikuu 28, 2018, 13:14 »
No niin, nyt tätä projektia saatu hieman etiepäin.
C128d ei toimi edes ulkoisella levykeasemalla.
Nyt purettu ja todettu ainakin U1 6526A-1 rikkinäiseksi. Samaten levykeaseman U20 6526A-1 on rikki.
Epäilen vielä tota U16 7406, koska pin 8 löytyi 5v jännite. Sitähän siellä ei pitännyt olla, vaan pinnissä 14 on 5v.
Kyseisiä piirejä ei minulta nyt löydy, mutta jos jollain täällä foorumilla on EHJIÄ voin ostaa pois.
Laitoin ne tilaukseen, mutta jos lähempää löytyis ja nopeammin. Tarvis vähintään 2kpl.

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #7 : Tammikuu 28, 2018, 13:19 »
Samalla, kun katsoin virtalähteen kondensaattorit ja uusia tilatessa, tein muutoksen tohon ärsyttävän kovaääniseen tuulettimeen.
Toki se on nyt hieman matalampaa mallia, mutta tarvii hommata 25 paksu, jos tuo 15 paksu ei riitä. Nyt toki tuommonen silent versio ja ääntä ei ole juuri ollenkaan. Saa oikeen kuullostella korva kiinni koneessa, että pyöriikö tuuletin 😁
Pistäkää yv:tä, jos teiltä löytyy 6526A-1 piirejä.

Jos vaihtaa tuommossen ohkasemman tuulettimen, joutuu uusimaan tuulettimen m4 ruuvit. Itse käytin m4x20 pitkää uppokantaa, jolloin se oli pituudeltaan todella hyvä.
Suosittelen tätä tuulettimen vaihtoa. On se vaan niin pirun hiljanen nyt :)
« Viimeksi muokattu: Tammikuu 28, 2018, 21:03 kirjoittanut junnu78 »

Poissa virgo

  • Vuoden Foorumilainen 2014
  • Metusalem
  • ******
  • Viestejä: 1046
  • Retroilija henkeen ja vereen
    • Profiili
    • Genetic point web
Vs: Commodore 128d levykeasema
« Vastaus #8 : Tammikuu 29, 2018, 18:39 »
U16 katsoppa mitä löytyy pinnistä 9
pinnissä 8 pitäisi olla sama ivertoituna (käänteisenä)
8 pinissä on myös +5 ylösveto vastukset ( 1k )

vinkkinä voisin sanoa että 6526 = 8520 on sama piiri suuremmalla nopeus luokituksella (7-8Mhz)

( kyseinen piiri hoitelee Amigan CIAt )
« Viimeksi muokattu: Tammikuu 29, 2018, 18:41 kirjoittanut virgo »
Genetic-point Amiga BBS: g-point.tunk.org ports 500 & 1024
Genetic-PET C64 BBS:g-pet.tunk.org port 1025
or g-point.tunk.org port 1025

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #9 : Tammikuu 31, 2018, 18:50 »
Nyt saavutettu työvoitto. Commodore toimii nyt ulkoisella levykeasemalla.
Tuolta oli mennyt muutamat diodit.
1N914B diodia ei paikallisesta myymälästä löytynyt, mutta suunnilleen vastaavaa 1N4148 diodia kylläkin. Myös 6526 oli rikki.
Nyt ei vilku enää sisäisen levykeaseman valo, palaa virrat päällä kokoajan, moottoripyörii taukoamatta.
Myös jos aseman liittimet kytkee ja laittaa koneen päälle, se käynnistyy, mutta ilman ready tekstiä ja kursoria.
Virtaliittimen kun irroittaa ja käynnistää uudelleen, käynnistys toimii normaalisti ready ja kursoria myöten.

Noita diodeita juotellessa, tuli huomattua korroosiota 128 piirilevyn juotospuolella. Samanlaista, mitä tulee esim amigan sisäisen pariston vuotaessa.
Viinietikalla tullut nyt sitä putsailtua.
Tarvii vielä tarkemmin ja paremmin sitä putsailla.
Lisätä lakka lopuksi kohtiin jossa kuparoinnit tulevat näkyviin.

Poissa virgo

  • Vuoden Foorumilainen 2014
  • Metusalem
  • ******
  • Viestejä: 1046
  • Retroilija henkeen ja vereen
    • Profiili
    • Genetic point web
Vs: Commodore 128d levykeasema
« Vastaus #10 : Helmikuu 01, 2018, 17:58 »
haiskataa pahasti Reset ongelmalta 74ls14
Genetic-point Amiga BBS: g-point.tunk.org ports 500 & 1024
Genetic-PET C64 BBS:g-pet.tunk.org port 1025
or g-point.tunk.org port 1025

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #11 : Helmikuu 01, 2018, 19:23 »
Unohtu lisätä että c64 puolella kursori tulee. Ja vilkkuu normaalisti.

Poissa junnu78

  • Metusalem
  • *****
  • Viestejä: 179
  • Commodore for ever!
    • Profiili
Vs: Commodore 128d levykeasema
« Vastaus #12 : Helmikuu 11, 2018, 19:41 »
74ls14 ei ollut syynä. Tarvii vielä tutkiskella, jos vika tuolta vielä löytyis.