Kirjoittaja Aihe: C64C musta ruutu  (Luettu 741 kertaa)

Poissa mth_84

  • Tulokas
  • *
  • Viestejä: 4
    • Profiili
C64C musta ruutu
« : Syyskuu 25, 2018, 12:30 »
Moro
Aiheena olisi c64c kunnostus. Laite jäi tauolle muistaakseni -91 kun osa näppäimistä jätti toimimatta ja heti perään 2018 käynnistin koneen. Ongelmana kuitenkin ettei lättä tv näytä mitään. No aikani säädettyä totesin että koneessa olisi vikaa. (Sain vanhan putki matkatv lainaan mutta sekin oli hajalla :-\)

Olen tässä nyt lyhyellä sähköopilla mittaillut:
-5v jännitteet ok piireille saakka (max n.5.2v lämmetessään)
-virransyöttö pelaa 9vac, 5v can, 9v unregulated on 11v luokkaa, 12v ok
-piirit ei kuumene paitsi vic-2 joka ilmeisesti normaalia
- jonkin vanhan troubleshooting mukaan mittailin ja vikoja löysin u31 pinni 13 taajuus sekavaa. (Pitäisi olla 14.7hz). CN5 pinnit 4 1.64v (2vdc) ja pinni 6 20mV (1V). Ja color pinni 21 u19 17.72hz (oikea 14.7hz)

Mitähän tämän kanssa tekisi, haluaisin tämän itse korjailla ihan mielenkiinnosta..

Niin ja sokkokomentoja ei oikein pysty koittamaan koska muistaakseni L näppäin ei toiminut. Ainoa lämmennyt kohta levyllä on u2 pohja. Voisiko tämä CIA piiri selittää näppäimet ja koko laitteen pimenenemisen? Kytkettäessä kasettisoitin pyörähtää sek ja jos esim play pohjassa käynnistää jää laite pyörimään..
« Viimeksi muokattu: Syyskuu 27, 2018, 15:29 kirjoittanut mth_84 »

Poissa fmatic

  • Ylläpito
  • Metusalem
  • *****
  • Viestejä: 573
  • Respect My Authority!!!!
    • Profiili
    • RaivoGalleria
Vs: C64C musta ruutu
« Vastaus #1 : Syyskuu 27, 2018, 06:28 »
Kelju kun tuossa levyssä ei näköjään CIA-piirit ole kannalla. Olisi helppo testata kun nyppäisi molemmat tai toisen pois. Kone käynnistyy ilman niitäkin, tosin kursoria ei tule näytölle. Sama homma SID-piirin kanssa eli käynnistyy ilman sitäkin. Vois hyvinkin olla vikaa CIA:ssa jos osa näppäimistä ei toimi.

Testasin piruuttaan omalla ASSY 250466 levyllä, jossa CIA-piirit ovat kannalla nostamalla piirejä hieman irti ja tuloksena oli musta ruutu...
« Viimeksi muokattu: Syyskuu 27, 2018, 06:38 kirjoittanut fmatic »

Poissa mth_84

  • Tulokas
  • *
  • Viestejä: 4
    • Profiili
Vs: C64C musta ruutu
« Vastaus #2 : Syyskuu 27, 2018, 15:26 »
Edistystä tapahtunut.  :thumbup:

Rakentelin s-video piuhan scart johdosta. Sain kuin sainkin av kautta kuvan näkymään. Laite käynnistyy ja kuva tulee normaalisti sinisenä ja bordereilla. Näytössä kuitenkin pelkkää $  $ $ merkkejä, ei reagoi mihinkään.

Pitää jatkaa tutkimista. Jos ideoita arvon raadilla, apu otetaan vastaan.
« Viimeksi muokattu: Syyskuu 27, 2018, 15:30 kirjoittanut mth_84 »

Poissa fmatic

  • Ylläpito
  • Metusalem
  • *****
  • Viestejä: 573
  • Respect My Authority!!!!
    • Profiili
    • RaivoGalleria
Vs: C64C musta ruutu
« Vastaus #3 : Syyskuu 27, 2018, 21:08 »
Nuo epämääräiset merkit sopisi moneenkin. The Pictorial C64 Fault Guidesta voi käydä hämmästelemässä lisää. https://derbian.webs.com/c64diag/

Ihan arvailua, mutta jos tuo U2 CIA lämpenee normaalia enemmän lähtisin tutkimaan sitä. Juotokset sun muut ja lopuks piiri irti ja katsomaan häipyykä dollarimerkit sen ollessa irti...

Poissa mth_84

  • Tulokas
  • *
  • Viestejä: 4
    • Profiili
Vs: C64C musta ruutu
« Vastaus #4 : Syyskuu 27, 2018, 22:51 »
U1 ja U2 otettu irti ja kannoitettu. Vika ei muutu vaikka molemmat irti. SID irti ei myöskään muutosta.

U2 kanta on lämmennyt kortin alapuolelta (lakka tummunut joka nastan kohdalta) mutta piiri ei tunnu käyvän muita kuumempana.

Inframittarilla mittailin noita piirejä ja VIC on se kuumin. Mittarin mukaan parhaimmillaan +65. Lämpöeristys lähtenyt ilmeisesti irti liimauksistaan joskus kauan sitten, sen näköinen päältä. Muut lämpimän tuntuiset pyörii siinä 40-50 välillä.

Poissa virgo

  • Vuoden Foorumilainen 2014
  • Metusalem
  • ******
  • Viestejä: 1082
  • Retroilija henkeen ja vereen
    • Profiili
    • Genetic point web
Vs: C64C musta ruutu
« Vastaus #5 : Syyskuu 29, 2018, 16:32 »
oletko kokeillut moduuleilla konetta käyntiin ?

tuo vaikuttaa väylä tai rom vialta...
Genetic-point Amiga BBS: g-point.tunk.org ports 500 & 1024
Genetic-PET C64 BBS:g-pet.tunk.org port 1025
or g-point.tunk.org port 1025

Poissa mth_84

  • Tulokas
  • *
  • Viestejä: 4
    • Profiili
Vs: C64C musta ruutu
« Vastaus #6 : Lokakuu 10, 2018, 18:09 »
Moduuleja en ole ikinä omistanut..
Vaihdoin pitkälle melkein kaikki piirit uusiin ja kannoitin kaikki. Lopulta muistit vaihtamalla heräsi ja pelaa ja lataa.
Ainoa vika mikä edelleen on se -91 vuoden perintö että yksi column ei näppäimissä toimi. U2-U1 sekoittamalla saa pelaamaan senkin, quickshot 2 en saanut toimimaan. Tai ainoa peli mikä löytyi tähän hätään Rick dangerous 2 pitäisi fireä painaa, mutta ei liipaissut. Voisiko se johtua tuosta U1 myös? Ei mielestäni muuttunut U2-U1 sekoituksella....

Olisiko jollain myydä 1 tai vaikka molempia CIA ?